Download all Joomla templates including quickstart (demo)only $24.99

Forum

Important - Hands Up!

- Please ask using the account with which you made the purchase or download of our products and in its respective category.
- If you bought our products in another market, ask your questions in that market, not here.

* ADD PRODUCT NAME IN START OF SUBJET

Barbon - Google Fonts integrate locally

  • S
  • spike Premium Member
  • Topic Author 1 year 6 months ago #1
I use Font Poppins from Google-Fonts. How can I integrate this font locally on our server to be privacy compliant? Thanks in Advance.

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 6 months ago #2
We have created a special guide for you, the steps to follow are here. www.unitemplates.com/blog/joomla/how-to-...ocal-fonts-to-joomla
The following user(s) said Thank You: spike

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 6 months ago #3
Works perfect and DSGVO conform now. Thank you very much!

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 6 months ago #4
After some tests with locally installed Google Fonts i have to found out, that iframe shows not the installed google fonts, only a standard fonts.

Please look at following link and click "Benachrichten Sie mich, wenn das Produkt wieder verfügbar ist":
This message contains confidential information


How can I show locally Google Font also for iframes?

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 6 months ago #5
You cannot change the styles or the font of the content of an iframe from the page or domain in which the iframe is loaded, and even less if the iframe is external (that is, from another domain that does not belong to you)

If the iframe is from the same domain, or the other domain the iframe comes from is owned by you, you need to add custom.css to the file that generates the iframe. That is the process but we do not know what file generates that iframe so you must contact the developer of the extension
The following user(s) said Thank You: spike

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #6
Hello,

I followed your instructions. But Google font links are still displayed in the code. How can I delete this code?

<link href=" fonts.googleapis.com/css?family=Roboto:3...rillic-ext,latin-ext " rel="stylesheet" />

<link href="//fonts.googleapis.com/css?family=Poppins:100,100italic,200,200italic,300,300italic,400,400italic,500,500italic,600,600italic,700,700italic,800,800italic,900,900italic&display=swap" rel="stylesheet" />

This message contains confidential information


Because is part of the Helix framework and template.

With the Google Font links we are in danger of being expensive warned from lawyers here in Germany.



Thanks in Advance

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 4 months ago #7
I have reviewed your site and the link code to Google fonts does not exist. Please verify or confirm that the code does not exist

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #8
Thanks for answer. At our Main-Domain Google font Links manually disabled via DSGVO Tool.

Please check our Testdomain:
Part of the message is hidden for the guests. Please log in or register to see it.


You can found the Link there.

Can you help me, how we can remove the both links?

I´m Wondering, The Font "Roboto" we don´t use. Only Poppins.

Best regards

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 4 months ago #9
From what I see you seem to have not fully followed the tutorial. You must disable Google fonts in all template styles, because they work independently.

The other problem that it may be loading is that in SP Page Builder you have selected a font, because in the template code nowhere do we add the direct link to any Google font.

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #10
ok, I don't know where else I would have activated google fonts. I have only two frontend Templates active and on both Google Fonts are deactived. And Google fonts are centrally deactivated via page builder settings.

I'll have to take a closer look, but I don't know where.

Thank you.
Attachments:

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 4 months ago #11
Some third party extension may be adding?.
Share screenshot of Helix font configuration

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #12
Here is the screenshot of helix Font Configuration.
Attachments:

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 4 months ago #13
have the same settings in all Template Styles?

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #14
yes, definitly.

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #15
but this link is still present

<link href=" fonts.googleapis.com/css?family=Roboto:3...rillic-ext,latin-ext " rel="stylesheet" />

And Roboto is still not in use

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #16
Found it: third party extension ""Google Review Pro" .....

Blast it!

Everything is ok now, own fault! Sorry

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 4 months ago #17
I have verified again, now if the Helix Google fonts (or template that is what corresponds to us) are turned off, these fonts are added with // at the beginning. But currently you have a roboto font added with https:// that font is not added in the template, maybe it will be added with other extension

Please Log in or Create an account to join the conversation.

  • S
  • spike Premium Member
  • Topic Author 1 year 4 months ago #18
Yes you´re right. I´ve found the malefactor, it was a thrd Party Component "Google Review Pro"

the template works absolutly correct.

Thanks for your help.

Best regards.

Please Log in or Create an account to join the conversation.