Download all Joomla templates including quickstart (demo)only $24.99

Forum

Important - Hands Up!

- Please ask using the account with which you made the purchase or download of our products and in its respective category.
- If you bought our products in another market, ask your questions in that market, not here.

* ADD PRODUCT NAME IN START OF SUBJET

helix 0 Path cannot be empty

  • A
  • Aleksej Senior Member
  • Topic Author 1 year 7 months ago #1
Hello. I can't edit style (template) settings if PHP 8.0 is enabled on the hosting. With PHP 7.4 everything is fine. The technical support of the hosting said that the problem is not on their side.
I can provide access to the admin panel and FTP of the site.
Please, help. Thanks in advance.
Attachments:
The topic has been locked.
  • A
  • Aleksej Senior Member
  • Topic Author 1 year 7 months ago #2
Here is the access data:

This message contains confidential information
The topic has been locked.
  • L
  • leoalv Moderator
  • 1 year 7 months ago #3
I don't know if it's correct that it's because of PHP 8, our development server is in PHP 8.0.13 and we don't have that problem. What I see in the image is that your site is in Nginx not Apache. Another likely cause is that after installation you have enabled HTTP Security Headers or maybe Nginx needs this to be enabled.

We have not been able to access because the url responds with this error 403 of access prohibited. also the url is wrong it says -com when it should be .com
The topic has been locked.
  • A
  • Aleksej Senior Member
  • Topic Author 1 year 7 months ago #4
"We have not been able to access because the url responds with this error 403 of access prohibited. also the url is wrong it says -com when it should be .com" - sorry, I was wrong. Here is the correct data:
This message contains confidential information
The topic has been locked.
  • A
  • Aleksej Senior Member
  • Topic Author 1 year 7 months ago #5
"Another likely cause is that after installation you have enabled HTTP Security Headers or maybe Nginx needs this to be enabled." - it needs to be done on hosting? What exactly should I do?
The topic has been locked.
  • L
  • leoalv Moderator
  • 1 year 7 months ago #6
The problem is not directly related to the files of our template, I have installed the original Helix ultimate and it has the same problem and the strict-origin-when-cross-origin error is not from the files, it is a server problem in this case your provider has to configure this in Nginx
The topic has been locked.
  • A
  • Aleksej Senior Member
  • Topic Author 1 year 7 months ago #7
I received a response from hosting technical support:

"The problem is in the site code, the 500 response is given by site scripts as a stub for errors. The essence of the problem in the file /libraries/src/Cache/Storage/FileStorage.php

Look, there are lines like:

$_fileopen = @fopen($path, 'wb');

So the $path variable should contain a string, but it's not a string, but an empty value. For the test, we added such checks in the code i.imgur.com/GLKOAtc.png and i.imgur.com/nWmkYyf.png and how the page i.imgur.com/ looks after that 7QoEI6a.png

Warning is there by itself, because the variable is missing due to checks, but as you can see, the reason is in the code. As for the strict-origin-when-cross-origin header, that's normal and not the cause of the problem."

What should I do? Contact Helix ultimate technical support? Or a problem in Joomla?

Attachments:
The topic has been locked.
  • L
  • leoalv Moderator
  • 1 year 7 months ago #8
We have solved your problem, probably your files were damaged, it can happen when updating, decompressing, uploading by ftp or you had installed version 4.2.0 of Joomsla that was defective.
We have updated to Joomla 4.2.3 and it works perfectly.

regards
The following user(s) said Thank You: Aleksej
The topic has been locked.
  • A
  • Aleksej Senior Member
  • Topic Author 1 year 7 months ago #9
Thank you. Problem solved. The question is closed.
The topic has been locked.