Download all Joomla templates including quickstart (demo)only $24.99

Forum

Important - Hands Up!

- Please ask using the account with which you made the purchase or download of our products and in its respective category.
- If you bought our products in another market, ask your questions in that market, not here.

* ADD PRODUCT NAME IN START OF SUBJET

Joomstagram - Images ara not displayed from token regeneration

  • C
  • c314 New Member
  • Topic Author 1 year 7 months ago #1
Hi,

My token expired and I just renewed after upgraded the Joomla to 4.2.3. The problem is the error has disappeared, but the images are not shown. What I've tried is ...

- The token is well generated: I'm sure it's right, because the error has no loger shown
- There are no new updateds (I'm running 3.0.0)
- The imatges ara still on my cache folde with the right permissions (755)
- There are not HTML errors on my page (you can see yourself at elpipo.es/viajes/quienes-somos/instagram)

Maybe there are problems with the lastest Joomla version ? If not, what more can I try ?

Regards,

Carles

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 7 months ago #2
You need to enable SSL first because you have a problem with Cross-Origin-Opener-Policy.
About the module I see that you are embedding it inside an article, we have never tested it like that (although it should work) unless Joomla 4.2.3 is not running the module inside the article for some reason.

Try to use as a module in some position and if it works it would be a compatibility problem with Joomla articles, which would lead us to investigate if we are the problem or the Joomla Articles.

Have you checked if the code {module.....} is present in the articles? or maybe Joomla 4 is cleaning it up.

PS: We are using this module in a position in J 4.2.3 in the new template we are developing and it works perfectly.

Regards

Please Log in or Create an account to join the conversation.

  • C
  • c314 New Member
  • Topic Author 1 year 7 months ago #3
Hi, thanks for your quick answer !

About the CSS, I don't have enable the SSL because I don't have a valid certificated (it's on my to do list :(

About how to include the Instragram feed, I'm doing it as a module assigned to a space on my template (standart template from Joomla 4.X, Favourite), to be precise, at "main-bottom", and it's only displAyed on "Instagram" article, that is completely empty.

I tried to assign directly the module as a menu option, but it doesn't appears as a "menu item option".

This method works for my on with other modules, but if you want (and you explain me how to do it), I'll try another way.

Regards,

Carles

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 7 months ago #4
I have checked the DOM, the module is generated correctly until the items wrapper, only the items do not exist, and that happens only when there are no items in instagram.

Go to the cache of your site and delete the instagram images generated by the module, then refresh the page and check if the images have been created again, if the images are not created it means that the token is badly generated

regards

Please Log in or Create an account to join the conversation.

  • C
  • c314 New Member
  • Topic Author 1 year 7 months ago #5
It works for me, thanks again !!!! ;)

Carles

Please Log in or Create an account to join the conversation.

  • L
  • leoalv Moderator
  • 1 year 7 months ago #6
What was the problem and how did you solve it? your answer may help others having the same problem. Regards

Please Log in or Create an account to join the conversation.

  • C
  • c314 New Member
  • Topic Author 1 year 7 months ago #7
So sorry to not clarify my answer: I deleted the archives from the cache folder, and then refresh the content.

Carles

Please Log in or Create an account to join the conversation.